WordPress Plugin Warning: Cannot modify header information…

Im Laufe einer Plugin-Entwicklung für die Website hps-systemtechnik.com, bin ich auf folgenden Fehler gestoßen:

Warning: Cannot modify header information - headers already sent by (output started at ...\wordpress\wp-content\plugins\hpsSideNavigation\sidenavi.php:1) in ...\wordpress\wp-includes\pluggable.php on line 890

Im Internet kann man einige Informationen darüber finden, doch in meinem konkreten Fall sah die Lösung etwas spezieller aus: der Fehler wurde dadurch hervorgehoben, dass eine der Include-Dateien, hier sidenavi.php, in einer „falschen“ Kodierung vorlag. Ursrünglich war es ASCII, da ich aber Umlaute haben wollte, habe ich es auf UTF-8 geändert. Ändert man den Zeichensatz wiederum auf  „UTF8 – without BOM“, dies kann man z.B. mit dem Open-Source-Texteditor Notepad++ tun, so tritt der Fehler nicht mehr auf und man kann mit den Arbeiten fortfahren.

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Schreibe einen Kommentar